Links

Downgrade Jakarta Servlet API to 5.0 when using Jetty

org.openrewrite.java.spring.boot3.DowngradeServletApiWhenUsingJetty _Jetty does not yet support Servlet 6.0. This recipe will detect the presence of the spring-boot-starter-jetty as a first-order dependency and will add the maven property jakarta-servlet.version setting it's value to 5.0.0. This will downgrade the jakarta-servlet artifact if the pom's parent extends from the spring-boot-parent. _

Tags

  • spring
  • jetty
  • boot

Source

  • groupId: org.openrewrite.recipe
  • artifactId: rewrite-spring
  • version: 4.32.0

Usage

This recipe has no required configuration options and can be activated directly after taking a dependency on org.openrewrite.recipe:rewrite-spring:4.32.0 in your build file:
Gradle
Maven POM
Maven Command Line
build.gradle
plugins {
id("org.openrewrite.rewrite") version("5.34.0")
}
rewrite {
activeRecipe("org.openrewrite.java.spring.boot3.DowngradeServletApiWhenUsingJetty")
}
repositories {
mavenCentral()
}
dependencies {
rewrite("org.openrewrite.recipe:rewrite-spring:4.32.0")
}
pom.xml
<project>
<build>
<plugins>
<plugin>
<groupId>org.openrewrite.maven</groupId>
<artifactId>rewrite-maven-plugin</artifactId>
<version>4.39.0</version>
<configuration>
<activeRecipes>
<recipe>org.openrewrite.java.spring.boot3.DowngradeServletApiWhenUsingJetty</recipe>
</activeRecipes>
</configuration>
<dependencies>
<dependency>
<groupId>org.openrewrite.recipe</groupId>
<artifactId>rewrite-spring</artifactId>
<version>4.32.0</version>
</dependency>
</dependencies>
</plugin>
</plugins>
</build>
</project>
shell
mvn org.openrewrite.maven:rewrite-maven-plugin:4.39.0:run \
-Drewrite.recipeArtifactCoordinates=org.openrewrite.recipe:rewrite-spring:4.32.0 \
-DactiveRecipes=org.openrewrite.java.spring.boot3.DowngradeServletApiWhenUsingJetty
Recipes can also be activated directly from the command line by adding the argument -Drewrite.activeRecipes=org.openrewrite.java.spring.boot3.DowngradeServletApiWhenUsingJetty

Definition

Recipe List
Yaml Recipe List
---
type: specs.openrewrite.org/v1beta/recipe
name: org.openrewrite.java.spring.boot3.DowngradeServletApiWhenUsingJetty
displayName: Downgrade Jakarta Servlet API to 5.0 when using Jetty
description: Jetty does not yet support Servlet 6.0. This recipe will detect the presence of the `spring-boot-starter-jetty` as a first-order dependency and will add the maven property `jakarta-servlet.version` setting it's value to `5.0.0`. This will downgrade the `jakarta-servlet` artifact if the pom's parent extends from the spring-boot-parent.
tags:
- spring
- jetty
- boot
recipeList:
- org.openrewrite.maven.AddProperty:
key: jakarta-servlet.version
value: 5.0.0
preserveExistingValue: false
trustParent: false

See how this recipe works across multiple open-source repositories

Moderne Link Image
The Moderne public SaaS instance enables you to easily run recipes across thousands of open-source repositories.
Please contact Moderne for more information about safely running the recipes on your own codebase in a private SaaS.